Tu servidor está ejecutando la versión de PHP, pero WordPess 3.0.5 necesita, al menos, la versión 5.2.